Настройка OSPF для нескольких зон.

В этой статье мы обсудим процесс настройки протокола маршрутизации OSPF в случае использования нескольких зон (multiarea OSPF). Предполагается, что читатель ознакомился с предыдущей статьёй, в которой мы обсудили теоретические аспекты работы OSPF с несколькими зонами, виды LSA пакетов, роли маршрутизаторов в OSPF и прочие важные вещи. По этой причине, в данной статьей мы не будем останавливаться на терминах и обсудим непосредственно настройку.

Перед началом настройки необходимо иметь на бумаге топологию, список используемых адресов, планируемое количество клиентов и устройств. Распределить зоны.

Предположим, что имеется следующая топология, для простоты будем эмулировать интернет и локальный сети за R2 и R3 с помощью loopback интерфейсов. Адресная таблица имеет следующий вид:

  • Сеть между R1 и R2 – 192.168.12.0/24
  • Сеть между R1 и R3 – 192.168.13.0/24
  • Сеть на Lo0 на R1 (в интернет) 192.168.0.0/24
  • Локальная сеть за R2 Lo0 – 192.168.2.0/24
  • Локальная сеть за R3 Lo0 – 192.168.3.0/24

Топология multiarea OSPF

Начнём настройку с маршрутизатора R2 – он будет ABR, так как находится на границе между зонами 0 и 1:

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface lo0
R2(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#interface Fa0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R2(config-if)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.2.0 0.0.0.255 area 1
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0

Две сети, подключенных к данному маршрутизатору относятся к разным area, поэтому маршрутизатор ABR. Аналогично настроим R3:

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface lo0
R3(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#interface Fa0/0
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.3.0 0.0.0.255 area 2
R3(config-router)#network 192.168.13.0 0.0.0.255 area 0
R3(config-router)#exit

Теперь настроим R1, у него внутренние интерфейсы находятся в area 0, а внешний (lo0) – находится за пределами OSPF вообще, через него выходит наружу статический маршрут по умолчанию, то есть этот маршрутизатор – ASBR.

Начнём с настройки интерфейсов:

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Fa1/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
R1(config-if)#interface Fa1/1
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up
R1(config-if)#exit
R1(config)#interface Lo0
R1(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#exit

Добавим статический маршрут по-умолчанию, ведущий за пределы OSPF домена:

R1(config)#ip route 0.0.0.0 0.0.0.0 Lo0

Настраиваем маршрутизацию, добавив строчку «default-information originate» чтобы маршрутизатор сообщал другим о своём маршруте по умолчанию:

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#network 192.168.13.0 0.0.0.255 area 0
R1(config-router)#default-information originate
R1(config-router)#
00:25:16: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet1/0 from LOADING to FULL, Loading Done
00:25:19: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on FastEthernet1/1 from LOADING to FULL, Loading Done

Настройка маршрутизации завершена, посмотрим, как выглядят маршруты на R1:

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
C    192.168.0.0/24 is directly connected, Loopback0
     192.168.2.0/32 is subnetted, 1 subnets
O IA    192.168.2.1 [110/2] via 192.168.12.2, 00:00:26, FastEthernet1/0
     192.168.3.0/32 is subnetted, 1 subnets
O IA    192.168.3.1 [110/2] via 192.168.13.3, 00:00:36, FastEthernet1/1
C    192.168.12.0/24 is directly connected, FastEthernet1/0
C    192.168.13.0/24 is directly connected, FastEthernet1/1
S*   0.0.0.0/0 is directly connected, Loopback0

Ожидаемая картина: маршрут по умолчанию статичиский (S*), а маршруты во внутренние сети 192.168.2.0 и 192.168.3.0 – с пометкой O IA, что означает, что маршруты получены из других зон. Если посмотреть, как выглядит маршрут по умолчанию, например, на R3, то мы увидим:

R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is 192.168.13.1 to network 0.0.0.0
     192.168.2.0/32 is subnetted, 1 subnets
O IA    192.168.2.1 [110/3] via 192.168.13.1, 00:02:24, FastEthernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O    192.168.12.0/24 [110/2] via 192.168.13.1, 00:02:39, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.13.1, 00:02:39, FastEthernet0/0

O*E2 означает, что маршрут является внешним по отношению ко всему домену OSPF, а не только к текущей области. Маршрут ведёт за пределы домена. Все передаваемые маршруты из зоны в зону не суммируются, для суммирования сетей (с целью уменьшения таблицы маршрутизации), следует настроить суммаризацию маршрута в OSPF.

Топология в формате Packet Tracer доступна здесь.

Комментарии

Спасибо все доступно, понятней некуда объяснили. Статья просто клас!

Добавить комментарий